We’re investigating issues with users being able to access Instat.
Incident Report for Hudl
Resolved
This incident has been resolved.
Posted Oct 02, 2023 - 12:14 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 02, 2023 - 12:13 CDT
Identified
We have identified the issue and are working on a fix.

In the meantime, Please user these links to reach Instat:
- app.hudl.com/instat/basketball
- app.hudl.com/instat/hockey.

Some things may still not work on those links. We'll be back soon with more updates.
Posted Sep 28, 2023 - 16:16 CDT
Update
We are continuing to look into the issues surrounding accessing Instat and appreciate your patience.

In the meantime, you can reach Instat by going to app.hudl.com/instat/basketball or app.hudl.com/instat/hockey. Some things may still not work on those links. We'll be back soon with more updates.
Posted Sep 28, 2023 - 14:23 CDT
Update
We’re still looking into the issues surrounding accessing Instat. In the meantime, you can reach Instat by going to app.hudl.com/instat/basketball or app.hudl.com/instat/hockey. Some things may still not work on those links. We'll be back soon with more updates.
Posted Sep 28, 2023 - 11:52 CDT
Investigating
Some users are experiencing issues with accessing Instat. We are investigating and hope to have an update shortly.
Posted Sep 28, 2023 - 08:03 CDT
This incident affected: Hudl Instat.