Users are having issues accessing Hudl Fan
Incident Report for Hudl
Resolved
The incident has been resolved and users are able to access Hudl Fan normally.
Posted Sep 01, 2023 - 15:30 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2023 - 14:53 CDT
Identified
The issue has been identified and a fix is being implemented
Posted Sep 01, 2023 - 14:47 CDT
Investigating
We are currently investigating this issue.
Posted Sep 01, 2023 - 14:45 CDT
This incident affected: Hudl Fan.