Select users are experiencing slow loading times for hudl.com
Incident Report for Hudl
Resolved
Good news! Problems with slow loading times for hudl.com have been resolved. Thanks for your patience.
Posted Sep 27, 2023 - 09:03 CDT
Monitoring
We’ve applied a solution to the issue causing slow loading times.
Posted Sep 27, 2023 - 08:46 CDT
Investigating
We’re investigating issues with slow loading times and will have an update shortly.
Posted Sep 27, 2023 - 08:32 CDT
This incident affected: Hudl.com.