We’re investigating issues with the site and will have an update shortly.
Incident Report for Hudl
Resolved
All Hudl services are up and running.
Posted Sep 18, 2023 - 07:35 CDT
Monitoring
We believe we've fixed the issue affecting the site. We’re monitoring the results of this solution and will let you know once we know more. Thanks for sticking with us!
Posted Sep 18, 2023 - 07:22 CDT
Identified
The issues has been identified and we are working on a fix as we speak.
Posted Sep 18, 2023 - 06:58 CDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2023 - 06:43 CDT
This incident affected: Hudl.com.