Instat Site Performance
Incident Report for Hudl
Resolved
Good news! Problems with Instat site performance have been resolved. Thanks for your patience.
Posted Jan 27, 2024 - 16:48 CST
Identified
We’ve identified the cause of the Instat site performance issue and are working towards a solution.
Posted Jan 27, 2024 - 15:24 CST
Investigating
We’re investigating performance issues with Instat and will have an update shortly.
Posted Jan 27, 2024 - 13:02 CST
This incident affected: Hudl Instat.