Some users are getting a 404 Error Page when trying to access Hudl. We are investigating and hope to have an update shortly.
Incident Report for Hudl
Resolved
All Hudl services are up and running. Still having trouble? Contact us at support@hudl.com.
Posted Jul 05, 2023 - 08:01 CDT
Monitoring
We believe we have successfully fixed the issue that was leading to 404 Error Pages and are monitoring the results. Thanks for sticking with us!
Posted Jul 05, 2023 - 07:31 CDT
Update
We’re still looking into the issue that's leading to 404 Error Pages on Hudl. Thanks for your patience. We'll be back soon with more updates.
Posted Jul 05, 2023 - 07:11 CDT
Update
We’re still looking into the issue that's leading to 404 Error Pages on Hudl. Thanks for your patience. We'll be back soon with more updates.
Posted Jul 05, 2023 - 06:45 CDT
Update
We’re still looking into the issue that's leading to 404 Error Pages on Hudl. Thanks for your patience. We'll be back soon with more updates.
Posted Jul 05, 2023 - 06:27 CDT
Update
We are continuing to investigate this issue.
Posted Jul 05, 2023 - 06:12 CDT
Investigating
We are currently investigating the issue
Posted Jul 05, 2023 - 06:12 CDT
This incident affected: Hudl.com.