Users are Experiencing Issues with Reports Page
Incident Report for Hudl
Resolved
The issue has been resolved and teams should now be able to use the Reports page as intended. Thanks again for your patience!
Posted Jan 05, 2024 - 10:10 CST
Monitoring
We've found the root cause of the reports page issue some of our users are experiencing and a solution to this problem is currently being implemented. Thanks for your patience. We'll share an update as soon as things are back up and running.
Posted Jan 05, 2024 - 09:22 CST
Investigating
We are currently investigating the issue with stats not populating in the reports section.
Posted Jan 05, 2024 - 08:47 CST
This incident affected: Hudl.com.